Merkit eivät näy...

Täällä voit antaa ehdotuksia ja yleistä palautetta sekä esittää kysymyksiä koko Kanjikaveri-sivustoa koskien.
HUOM! Jos et halua rekisteröityä foorumille, mutta haluat jättää kuitenkin palautetta, kirjaudu sisään tunnuksella "Vierailija" ja salasanalla "kanjikaveri".

Valvoja: Belorfyn

Merkit eivät näy...

ViestiKirjoittaja Vierailija » 21.09.2010 15:26

Tässäpä pienoinen ongelma: Japanin merkistötuki on asennettu koneelle, mutta jostain syystä merkit eivät näy. Mesessä ja Firefoxissa näkyy (tai näkyi, eräästä mainitsemattomasta syystä en voi käyttää enää Firefoxia), mutta Google Chromessa tai japaninkielisissä tiedostonimissä merkit eivät näy. Jostain syystä tosin osa merkeistä näkyy Kanjikaverissa, mutta suurin osa ei.

...oli ehkä vähän hassusti selitetty, mutta kuitenkin. Hjälp!
Vierailija
 
Viestit: 191
Liittynyt: 04.10.2008 11:21

ViestiKirjoittaja Karelian » 21.09.2010 17:32

Mikä käyttöjärjestelmä on kyseessä?

Huomaatko mitään säännönmukaisuuksia siinä, mitkä merkit näkyvät? Esimerkiksi näkyvätkö vain hiraganat ja katakanat, mutta eivät kanjit?
Karelian
 
Viestit: 24
Liittynyt: 06.03.2009 23:37

ViestiKirjoittaja Vierailija » 22.09.2010 14:36

Käyttöjärjestelmä on Windows XP Home Edition. Ja on siinä tavallaan säännönmukaisuutta... merkit näkyvät normaalin kirjoituksen seassa, mutta esim. taulukoissa, tiedostonimissä tai sanakirja.org:ssa merkit eivät näy ollenkaan.
Vierailija
 
Viestit: 191
Liittynyt: 04.10.2008 11:21

ViestiKirjoittaja Karelian » 22.09.2010 17:37

Tiedostonimet voi ehkä selittää käyttöjärjestelmällä. Muistelen itsekin että eivät toimineet XP:llä ellei käyttöjärjestelmän kieleksi ollut asetettu japani. En muista tarkkaa asetusta, mutta muistaakseni jostain asetuksesta voi säätää oletuskielen ei-UTF ohjelmille, mutta se luultavasti sotkee sitten esim suomen kieliset ohjelmat jotka eivät käytä UTF:aa, joten en välttämättä suosittele. Mutta siitä on tosiaan vuosia kun olen viimeksi XP käyttänyt, niin voin muistaa väärin.

Chromen kohdalla voi ehkä kokeilla laittaa fonttiasetuksista default encodingiksi UTF-8 (mitähän lie default encoding suomeksi... oletusmerkistö?). Jos ei auta niin sitten en osaa valitettavasti neuvoa. :(
Karelian
 
Viestit: 24
Liittynyt: 06.03.2009 23:37

UTF-8 vaiko ei?

ViestiKirjoittaja Vierailija » 08.01.2011 12:02

Moi!

Kiinnostuneena selattuani sivuja huomasin että eivät nuo merkit tosiaankaan näy muualla kuin sanakirjassa ja sitten joillakin sivuilla, missä kanjit ovat merkityt html-koodiin html-entiteetteinä eli esim. näin: 兄 (eli et-merkki, # ja numerokoodi ja ";". Tallensin sivun otsikolla "2. vuoden kanjit" ja avasin TextWrangler-ohjelmassa (mäkkiversio ainakin on olemassa) ja se sanoi heti aluksi että tiedosto on väärin formatoitu. Suomenkieliset ääkköset eivät näkyneet tuolla kyseisellä sivulla kun oli UTF-8 valittu merkistöksi, mutta kun valitsin ISO-Latin-15:sta (eli sen vanhanmallisen euromerkn sisältävän) koodaukseksi, alkoivat ääkköset näkyä. Kanjeja ja muita vierasperäisiä merkistöjä en saanut näkymään vaikka kokeilin kaikki kolme tarjolla olevaa japanilaista merkistöä.

Eli: Sivusto ei ole puhtaasti UTF-8 -merkistöllä kirjoitettu. Jos asia korjattaisiin, saataisiin luultavasti kaikki merkit näkymään jokaiselle jolla on riittävän hyvät ohjelmat. Selaimina kokeilin jo Google Chromea ja Safaria ja Firefoxia ja kaikilla sain täsmälleen samat tulokset.

Jos tarvitset apua ongelman ratkaisemiseen, ota reilusti yhteyttä. Sähköpostini on toni.maki-leppilampi@metropolia.fi.

t: Toni
Vierailija
 
Viestit: 191
Liittynyt: 04.10.2008 11:21

ViestiKirjoittaja Ianthe » 25.01.2011 11:50

en ole varma onko samaa ongelma vai mistä on kyse mutta kanjikaveri-sivustossa ei edellenkään näy kirjoitukset? nyt neljättä viikkoa menossa...? korjataanko asia?
Ianthe
 
Viestit: 18
Liittynyt: 05.04.2010 15:31
Paikkakunta: Jyväskylä

ViestiKirjoittaja hyperconjugated » 27.01.2011 15:32

Etusivulta

P�ivitykset & tiedotteet
2.1.2011 klo 17.45

Sivuilla on ongelmia merkist�jen kanssa: ��kk�set ja japanilainen kirjoitus eiv�t n�y oikein. Olen laittanut palveluntarjoajalle pyynn�n korjata vika, toivottavasti saavat sivut kuntoon mahdollisimman nopeasti. Sanakirja n�ytt�isi kuitenkin toimivan normaalisti...
Avatar
hyperconjugated
 
Viestit: 301
Liittynyt: 05.09.2006 19:51
Paikkakunta: Hki

ViestiKirjoittaja Silja » 27.01.2011 18:19

Jees, palveluntarjoaja lähtee vaihtoon heti kun vaan muilta hommiltani ennätän. Nyt on vaan sellainen huonompi tilanne, että töissä saisi istua vaikka 24/7, jos vain huvittaisi (eli ei) ja viikonloppukin jo osittain täyteen buukattu.

Noissa minun palvelimelle lataamien sivujen merkistökoodauksessa ei ole mitään vikaa, eli ovat utf-8 kuten pitääkin, mutta jotain jännää tapahtui palvelimen päässä 31.12. kun tämä vika alkoi. Olen lähettänyt ensimmäisen korjauspyynnön 31.12.2010 palveluntarjoalle, johon vastasivat ihan jo 10.1.2011 niinkin ytimekkäästi kuin "oletko yrittänyt vaihtaa merkistökoodausta?". Väänsin heti perään rautalangasta uuden viestin, jossa kerroin että kyllä, olen yrittänyt ja niin on moni muukin ja kerroin tarkemmin mitä on tapahtunut. Tuohon viestiin en saanut ikinä vastausta.

Tämän viikon maanantaina pyysin tuolta verkkotunnukseni siirtoavaimen, että saan sivut siirrettyä pois ja sen sainkin heti seuraavana päivänä (heidän asiakassivuillaan on kohta, josta siirtoavaimen voi käydä katsomassa itse, mutta ylläri, ylläri, ko. sivu ei toimi). Nyt ovat näköjään sulkeneet myös tuon merkistökoodausta käsittelevän palvelupyynnön, joten eivät ilmeisesti ole kiinnostunut tuosta merkistökoodausongelmasta (joka on muuten myös tuolla heidän asiakassivuillaan...). Eli merkistökoodausongelma on ja pysyy niin kauan että saan siirrettyä sivut uudelle palvelimelle.

Osan sivuista olenkin jo siirtänyt (ja kas kummaa merkit näkyvät kuten kuuluukin!), mutta kun olen fiksuna taltioinut koneelleni myös muuta tavaraa noihin samoihin kansioihin joissa kanjikaverin sivut ovat, niin joudun käymään kaikki kansiot yksi kerrallaan läpi ennen siirtoa palvelimelle... Taidanpa parantaa tapani ja jemmata ei-nettiin-kuuluvat tiedostot jatkossa johonkin muualle... ;) Joudun myös tekemään joka sivuun pari pientä muutosta, että ne toimivat, mutta se menee sukkelaan etsi-korvaa -toiminnolla.

Sitten onkin toinen juttu osaanko siirtää tämän foorumin tuonne uudelle serverille... Mutta ans kattoo ny ensin.
Avatar
Silja
Ylläpitäjä
 
Viestit: 896
Liittynyt: 13.08.2006 20:39
Paikkakunta: 札幌市/Sapporo


Paluu Palaute Kanjikaveri-sivuista

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 3 vierailijaa